勉強したことのメモ

Webエンジニア / プログラマが勉強したことのメモ。

Plesk12で特定ドメインにメールが送信できない際の対応方法

   2024/02/20  サーバー

Plesk12を利用しているサーバで特定のドメインのみメールが送信されなかった。メールログを確認してみると「This_address_no_longer_accepts_mail(翻訳:このアドレスではメールを受け付けません)」というログがあった。以下に対応方法をメモ。

 

原因

Plesk側でバーチャルホスト設定(サイト設定)を行っているドメインで、外部メールサーバへ配信しようとしてもローカル配信されるというのが原因の模様。

例えばPlesk側でhoge.comのサイト設定をしており外部メールサーバへメール送信しようとすると、@google.comや@yahoo.co.jpには届くが@hoge.com宛には届かない。

 

対応方法

以下ファイルの該当ドメイン(hoge.comでサイト設定している場合はhoge.com)をコメントアウトする。

/var/qmail/control/rcpthosts
/var/qmail/control/virtualdomains

その後qmailを再起動する。

service qmail restart

 

メールログの場所

/var/log/maillog

 

参考サイト

https://camcam.info/tips/1729

 - サーバー

  関連記事

AlmaLinux8.6にLAMP環境&WordPressを構築する方法
AlmaLinux8.6にLAMP環境&WordPressを構築する方法

だいぶ前にCentOS6系から7系に移行したが、7系も2024/6/30にサポー ...

Let's Encryptの自動更新時「Failed to renew certificate~」エラーの対応方法
Let's Encryptの自動更新時「Failed to renew certificate~」エラーの対応方法

CentOSからAlmaLinuxに移行後、初めてのLet's Encrypt更 ...

日本語込みのURLをRewriteRuleで書き換える方法
日本語込みのURLをRewriteRuleで書き換える方法

WordPressのパーマネントリンク的なことをhtaccessで実現したい。具 ...

Podmanで導入したPHPの設定ファイル(php.ini)変更と高速化に関する設定方法
Podmanで導入したPHPの設定ファイル(php.ini)変更と高速化に関する設定方法

Podmanで導入したPHPの設定ファイル(php.ini)の内容を変更したい。 ...

gzip圧縮とキャッシュをhttpd.confで設定する方法
gzip圧縮とキャッシュをhttpd.confで設定する方法

今まで共用サーバーで使っていたWordPressをVPSに移した。せっかくなので ...