MySQLでユーザー作成時にエラーが発生
2024/02/25
SSHからrootアカウントでMySQLにログインし、ユーザーを作成しようとすると「ERROR 1045 (28000): Access denied for user」みたいなエラーが出た。
一度exitでMySQLを抜けて以下アップグレードをする事で解決した。
mysql_upgrade -u root -p
元々ユーザーはrootしかなかったので他のアカウントでログインしていたということは考えられず原因は不明。
関連記事
-
-
MySQLにてORDER BYで並べ替える際に空のカラムは後ろに持ってくる方法
MySQLにてORDER BYで並べ替える際に空のカラムの場合は後ろに持っていき ...
-
-
MySQLのview(ビュー)で仮想的なテーブルを作成する方法
MySQL関連のサイトを見ているとview(ビュー)が云々という記事を見かけた。 ...
-
-
phpmyadminからプロセスの停止
重たいSQL文を叩いた際、どうにも処理できず メモリ使用率が100%から下がらな ...
-
-
MySQLで同一サーバーの異なるDB内のテーブルをJOINする
同一のMySQLサーバーでdb1データベースのtable1テーブルと、db2デー ...
-
-
MySQLで直近に挿入したオートインクリメントの値と次回挿入する値を取得する方法
phpとmysqliを使っている中で次回挿入するオートインクリメントの値と、前回 ...