勉強したことのメモ

Webエンジニア / プログラマが勉強したことのメモ

phpMyAdminにて指定したIPアドレスからのアクセスを制限する方法

   2024/05/22  サーバー

phpMyAdminにて指定したIPアドレスからのアクセスを制限する方法をメモ。

 

対応方法

サーバにSSH接続し以下で設定ファイルを開く。

vi /etc/httpd/conf.d/phpMyAdmin.conf

以下を追記する。

Order deny,allow
Deny from all
Allow from 127.0.0.1
Allow from 【開放したいIP】

当方の環境だと以下の中と、

<Directory /usr/share/phpMyAdmin/>
<IfModule mod_authz_core.c>

その少し下部分になる。

</IfModule>
<IfModule !mod_authz_core.c>

追記後はapacheの再起動をすることでアクセス制限が効くはず。

 - サーバー

  関連記事

CentOS7.9にPostfixをインストールしてメール送信できるようセットアップする方法
CentOS7.9にPostfixをインストールしてメール送信できるようセットアップする方法

本ブログのサーバをKAGOYAのVPSからWebARENA Indigoへ移行し ...

中国のIPアドレスをiptablesで拒否、遮断する
中国のIPアドレスをiptablesで拒否、遮断する

レンタルしているVPSの一つが最近よく落ちる。原因はどうも海外、特に中国から不正 ...

LAMP環境及びFTPサーバの各種設定ファイルのディレクトリまとめ
LAMP環境及びFTPサーバの各種設定ファイルのディレクトリまとめ

サーバ内の各種設定ファイルを編集する際にいつもfindコマンドで検索したり、ググ ...

Lightbox.jsでCSP(コンテンツセキュリティポリシー)エラーが発生した際の対応方法
Lightbox.jsでCSP(コンテンツセキュリティポリシー)エラーが発生した際の対応方法

CSP(コンテンツセキュリティポリシー)設定を行っているサーバーでLightbo ...

Sysstat Graphical Viewerにロードアベレージを追加
Sysstat Graphical Viewerにロードアベレージを追加

sysstatの各種情報をグラフ表示するSysstat Graphical Vi ...