勉強したことのメモ

Webエンジニア / プログラマが勉強したことのメモ

Plesk12で特定ドメインにメールが送信できない際の対応方法

   2024/02/20  サーバー

Plesk12を利用しているサーバで特定のドメインのみメールが送信されなかった。メールログを確認してみると「This_address_no_longer_accepts_mail(翻訳:このアドレスではメールを受け付けません)」というログがあった。以下に対応方法をメモ。

 

原因

Plesk側でバーチャルホスト設定(サイト設定)を行っているドメインで、外部メールサーバへ配信しようとしてもローカル配信されるというのが原因の模様。

例えばPlesk側でhoge.comのサイト設定をしており外部メールサーバへメール送信しようとすると、@google.comや@yahoo.co.jpには届くが@hoge.com宛には届かない。

 

対応方法

以下ファイルの該当ドメイン(hoge.comでサイト設定している場合はhoge.com)をコメントアウトする。

/var/qmail/control/rcpthosts
/var/qmail/control/virtualdomains

その後qmailを再起動する。

service qmail restart

 

メールログの場所

/var/log/maillog

 

参考サイト

https://camcam.info/tips/1729

 - サーバー

  関連記事

Lightbox.jsでCSP(コンテンツセキュリティポリシー)エラーが発生した際の対応方法
Lightbox.jsでCSP(コンテンツセキュリティポリシー)エラーが発生した際の対応方法

CSP(コンテンツセキュリティポリシー)設定を行っているサーバーでLightbo ...

CentOS 6.5にメールサーバ(postfix&dovecot)を導入する方法
CentOS 6.5にメールサーバ(postfix&dovecot)を導入する方法

CentOS 6.5にメールサーバ(postfix&dovecot)を導 ...

サーバ管理ツール「Cockpit」にファイルマネージャー用プラグインを導入する方法
サーバ管理ツール「Cockpit」にファイルマネージャー用プラグインを導入する方法

先日メモしたサーバ管理ツール「Cockpit」にブラウザ上からファイルの作成や編 ...

htaccessでスマホ判別とCookie制御する方法
htaccessでスマホ判別とCookie制御する方法

サイトを閲覧しているデバイスがスマホ且つ特定のCookieの値が入っているユーザ ...

AlmaLinux8系に異なるバージョンのPHPをインストールする方法
AlmaLinux8系に異なるバージョンのPHPをインストールする方法

AlmaLinux8系&Apache2.4系の環境に異なるバージョンのP ...