勉強したことのメモ

Webエンジニア / プログラマが勉強したことのメモ

中国のIPアドレスをiptablesで拒否、遮断する

   2024/01/12  サーバー

レンタルしているVPSの一つが最近よく落ちる。原因はどうも海外、特に中国から不正っぽいアクセスが大量にあった。

「全部遮断→日本のみアクセス許可」という方法だとGoogleBotも遮断されてしまい、検索順位が急降下してしまったので、「中国からのアクセスを遮断」という形を取った。

以下サイトより中国のIPアドレスを取得してiptablesで設定。

http://filtering.web.fc2.com/

設定後はロードアベレージも落ち着いたけどしばらく様子を見る。あとアメリカからのアクセスは許可しているのでGoogleBotは通るはずだけど検索順位とWebマスターツールも当面は要チェック。

 - サーバー

  関連記事

Cockpitでプログラムの自動実行(systemd timer)設定を行う方法
Cockpitでプログラムの自動実行(systemd timer)設定を行う方法

Cockpitでプログラムの自動実行設定を行いたい。調べたところCronは難しそ ...

AlmaLlinux8にsysstatを導入し、svgファイル出力したものをブラウザから閲覧する方法
AlmaLlinux8にsysstatを導入し、svgファイル出力したものをブラウザから閲覧する方法

以前CentOS系にsar(sysstat)を導入しSysstat Graphi ...

プロキシサーバの接続ログを確認する方法
プロキシサーバの接続ログを確認する方法

だいぶ前にVPSにプロキシサーバ(squid)を導入した。接続IPは指定している ...

Let's Encryptの自動更新時「Failed to renew certificate~」エラーの対応方法
Let's Encryptの自動更新時「Failed to renew certificate~」エラーの対応方法

CentOSからAlmaLinuxに移行後、初めてのLet's Encrypt更 ...

画像やPDF等のファイルへの直接アクセスは禁止し、PHP経由のみ表示やダウンロードを可能にする
画像やPDF等のファイルへの直接アクセスは禁止し、PHP経由のみ表示やダウンロードを可能にする

ファイルアップローダーを作成する案件があり、アップロードしたファイルは「http ...