勉強したことのメモ

Webエンジニア / プログラマが勉強したことのメモ

中国のIPアドレスをiptablesで拒否、遮断する

   2024/01/12  サーバー

レンタルしているVPSの一つが最近よく落ちる。原因はどうも海外、特に中国から不正っぽいアクセスが大量にあった。

「全部遮断→日本のみアクセス許可」という方法だとGoogleBotも遮断されてしまい、検索順位が急降下してしまったので、「中国からのアクセスを遮断」という形を取った。

以下サイトより中国のIPアドレスを取得してiptablesで設定。

http://filtering.web.fc2.com/

設定後はロードアベレージも落ち着いたけどしばらく様子を見る。あとアメリカからのアクセスは許可しているのでGoogleBotは通るはずだけど検索順位とWebマスターツールも当面は要チェック。

 - サーバー

  関連記事

AlmaLinux8系にNginxを導入しPodmanコンテナに接続する方法
AlmaLinux8系にNginxを導入しPodmanコンテナに接続する方法

AlmaLinux8でホスト側はApacheからPodmanコンテナ環境に接続し ...

OpenLightSpeedを触ってみた感触と使いどころについて
OpenLightSpeedを触ってみた感触と使いどころについて

ここのところOpenLightSpeedを色々試してみた。「Apacheとの互換 ...

Tera Termでコマンドのキャンセル
Tera Termでコマンドのキャンセル

Tera TermでSSH接続中にコマンドをキャンセルしたい場合は以下を入力する ...

OpenLiteSpeedにてhtaccessファイルでリライト、リダイレクトする方法
OpenLiteSpeedにてhtaccessファイルでリライト、リダイレクトする方法

OpenLiteSpeedでリライト、リダイレクト設定を行いたい。調べたところ管 ...

Apache2.4で[access_compat:error]AH01797エラーの対処方法
Apache2.4で[access_compat:error]AH01797エラーの対処方法

Apacheのエラーログを追っていると「[access_compat:error ...