中国のIPアドレスをiptablesで拒否、遮断する
2024/01/12
レンタルしているVPSの一つが最近よく落ちる。原因はどうも海外、特に中国から不正っぽいアクセスが大量にあった。
「全部遮断→日本のみアクセス許可」という方法だとGoogleBotも遮断されてしまい、検索順位が急降下してしまったので、「中国からのアクセスを遮断」という形を取った。
以下サイトより中国のIPアドレスを取得してiptablesで設定。
設定後はロードアベレージも落ち着いたけどしばらく様子を見る。あとアメリカからのアクセスは許可しているのでGoogleBotは通るはずだけど検索順位とWebマスターツールも当面は要チェック。
関連記事
-
-
WordPressのサーバー移行で気付いた点
あるWordPressを置いているサーバーのリソースが苦しくなってきたので、新た ...
-
-
Podmanで導入したApacheのチューニング(mpm_prefork)に関する設定方法
Podmanで導入したApacheのチューニング(mpm_prefork)を行い ...
-
-
Plesk12で「SQLSTATE[42S02]: Base table~~」エラー時の対応方法
Plesk12のログインページを開くと「ERROR: Zend_Db_State ...
-
-
SELinuxとは? またサーバ構築作業の際に何故SELinuxを無効にする必要があるのか?
サーバ構築作業の際に大抵「SELinuxは無効化しましょう」という案内がある。そ ...
-
-
ムームードメインで取得したドメインをムームードメイン側のDNSでエックスサーバを使う方法
ムームードメインでドメインを取得し、エックスサーバで使う場合にエックスサーバ側の ...