MySQLが起動も再起動もできない際の対応方法
2024/02/25
サイトで障害が発生した。FTPやSSH接続は出来るけどサイト自体は表示されない。MySQLが原因っぽいのでMySQLを再起動しても改善されず。また、サーバー自体を再起動しても改善されなかった。
TOPコマンドで動いているサービスを見ると、動いていないはずのMySQLがのっているというよく分からない状態だった。
結論として原因はサーバのHDDをフルに使っている状態だった。自動更新系のサイトだったので勝手に容量が増えていき、満タンになっていた。
便利だったコマンド
find /var -size +100M -exec ls -lh {} \;
100MB以上のファイルを検索する。古いログとかを抽出して消していけば良い。
MySQLのログ
/var/log/mysqld.logに保存されているので、エラー詳細を確認したい場合はこちらを見る。
その他
HDD容量を増やす事が出来れば一番楽だけど、難しい場合もある。日々のサーバーのチェックは前日のメモリ使用量だったり、ロードアベレージを見ていたけど、HDD使用率も念のため見ていたほうが良さそう。
関連記事
-
-
異なるVPS間でMySQLの接続を行う方法
異なるVPS間でMySQL接続を行った際のメモ。 対応方法 さくら ...
-
-
SortableJSを使ってデータの並べ替え&保存
あるシステムを拝見した際にtableタグ内に並んでいる項目をドラッグ&ド ...
-
-
SSH接続でMySQLにダンプファイルをインポートする方法
phpMyAdminやAdminerが入っていなかったり、ダンプファイルのサイズ ...
-
-
MySQLでテーブルのカラム名やカラムの型等、詳細情報を取得する方法
MySQLでテーブルのカラム名やカラムの型等、詳細情報を取得する方法をメモ。 & ...
-
-
さくらインターネットでCronからmysqldumpすると0バイトのファイルが生成される
さくらインターネットのレンタルサーバでmysqldumpした結果をファイルとして ...