MySQLが起動も再起動もできない際の対応方法
2024/02/25
サイトで障害が発生した。FTPやSSH接続は出来るけどサイト自体は表示されない。MySQLが原因っぽいのでMySQLを再起動しても改善されず。また、サーバー自体を再起動しても改善されなかった。
TOPコマンドで動いているサービスを見ると、動いていないはずのMySQLがのっているというよく分からない状態だった。
結論として原因はサーバのHDDをフルに使っている状態だった。自動更新系のサイトだったので勝手に容量が増えていき、満タンになっていた。
便利だったコマンド
find /var -size +100M -exec ls -lh {} \;
100MB以上のファイルを検索する。古いログとかを抽出して消していけば良い。
MySQLのログ
/var/log/mysqld.logに保存されているので、エラー詳細を確認したい場合はこちらを見る。
その他
HDD容量を増やす事が出来れば一番楽だけど、難しい場合もある。日々のサーバーのチェックは前日のメモリ使用量だったり、ロードアベレージを見ていたけど、HDD使用率も念のため見ていたほうが良さそう。
関連記事
-
-
WordPressサイトのロードアベレージが高い際の対応方法
あるWordPressサイトのロードアベレージが先月ぐらいまでは通常0.5前後で ...
-
-
MySQLで全角半角を区別せずに検索する方法(collate utf8_unicode_ci)
あるシステムでMySQLの検索時に「WHERE test_column coll ...
-
-
MySQLで1対多というテーブル構造でデータ結合と条件検索する方法
MySQLで飲食店舗テーブルと休業日テーブルがあり、1店舗に対して複数行の休業日 ...
-
-
MySQLで歯抜けになっているint型の数値を取得する
MySQLで歯抜けになっているシーケンス番号を 取得したいケースがあった。 ■ソ ...
-
-
MySQLのview(ビュー)で仮想的なテーブルを作成する方法
MySQL関連のサイトを見ているとview(ビュー)が云々という記事を見かけた。 ...