勉強したことのメモ

Webエンジニア / プログラマが勉強したことのメモ

MySQLが起動も再起動もできない際の対応方法

   2024/02/25  MySQL / MariaDB サーバー

サイトで障害が発生した。FTPやSSH接続は出来るけどサイト自体は表示されない。MySQLが原因っぽいのでMySQLを再起動しても改善されず。また、サーバー自体を再起動しても改善されなかった。

TOPコマンドで動いているサービスを見ると、動いていないはずのMySQLがのっているというよく分からない状態だった。

結論として原因はサーバのHDDをフルに使っている状態だった。自動更新系のサイトだったので勝手に容量が増えていき、満タンになっていた。

 

便利だったコマンド

find /var -size +100M -exec ls -lh {} \;

100MB以上のファイルを検索する。古いログとかを抽出して消していけば良い。

 

MySQLのログ

/var/log/mysqld.logに保存されているので、エラー詳細を確認したい場合はこちらを見る。

 

その他

HDD容量を増やす事が出来れば一番楽だけど、難しい場合もある。日々のサーバーのチェックは前日のメモリ使用量だったり、ロードアベレージを見ていたけど、HDD使用率も念のため見ていたほうが良さそう。

 - MySQL / MariaDB サーバー

  関連記事

MySQLでdatetime型のカラムから秒は省いて検索する方法
MySQLでdatetime型のカラムから秒は省いて検索する方法

MySQLでdatetime型のカラムに対して「2022-10-07 10:30 ...

MySQLでLIKE検索時に大文字・小文字・半角・全角全て区別したい
MySQLでLIKE検索時に大文字・小文字・半角・全角全て区別したい

以前にMySQLであいまい検索時に大文字小文字は区別しないが、それ以外は全て区別 ...

MySQLでスレッドの実行状況を表示しスレッドの経過時間チェックや特定スレッドを強制終了する方法
MySQLでスレッドの実行状況を表示しスレッドの経過時間チェックや特定スレッドを強制終了する方法

データベースサーバが重たく、原因を調査する機会があった。サーバ自体のメモリやCP ...

adminerでMySQLに接続しようとするとエラーになる場合の対応方法
adminerでMySQLに接続しようとするとエラーになる場合の対応方法

新しく構築したサーバにadminerを入れて接続しようとすると、「mysqlnd ...

MySQLでphpMyAdminやAdminer上だけ文字化けする場合の対応方法
MySQLでphpMyAdminやAdminer上だけ文字化けする場合の対応方法

レンタルサーバーのプログラムでWebページ上では文字化けしていないのに、phpM ...