勉強したことのメモ

Webエンジニア / プログラマが勉強したことのメモ

yumでupdateが出来ずepelがどうのこうのエラーが出た

   2024/01/12  サーバー

yumでupdate使用としたら「Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again」みたいなエラー表示が出た。以下に対応方法のメモ。

 

対応方法

同じ構成のサーバが複数台あって、その中の一つだけがこのエラーになった。epelのレポジトリが云々言っている感じなんだけど、果たしてどうしたらいいものか分からなかったので調べると、「/etc/yum.repos.d/repo」を修正すればよいとの事。

1~4行目辺りにある以下を、

[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch

以下に書き換える。

[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch

 

参考サイト

http://d.hatena.ne.jp/C_6B4A2B/20130427/1367073209

 - サーバー

  関連記事

他ドメインから画像の呼び出し(直リンク)を禁止する方法
他ドメインから画像の呼び出し(直リンク)を禁止する方法

他ドメインからの画像の呼び出し、いわゆる直リンクの禁止を行いたかった。調べるとh ...

中国のIPアドレスをiptablesで拒否、遮断する
中国のIPアドレスをiptablesで拒否、遮断する

レンタルしているVPSの一つが最近よく落ちる。原因はどうも海外、特に中国から不正 ...

サーバーリソース監視にsar(sysstat)が便利だった
サーバーリソース監視にsar(sysstat)が便利だった

過去にサーバーリソース監視のmuninとかcactiを何度か入れようとして挫折し ...

PodmanでMailpit用コンテナを作成しPHPからテストメールを送受信する方法
PodmanでMailpit用コンテナを作成しPHPからテストメールを送受信する方法

開発中などでPHPからテストメールを送信したい。以前メモしたmailtrapを使 ...

さくらのレンタルサーバーにお名前.comのサブドメイン設定
さくらのレンタルサーバーにお名前.comのサブドメイン設定

さくらのレンタルサーバーにお名前.comで取得・管理しているドメインの、サブドメ ...