PHP8系で「AdminNeo」「Adminer」が正常に動作しない場合の対応方法
PHP8.3と8.4系でAdminer6.0.1はログインページで表示崩れが発生、AdminNeo5.6.0は500エラーとなり正常に動作しなかった。サーバによっては問題無かったりもするので、恐らくPHP側の設定状況やモジュールの導入状況っぽいが原因は特定できず。とりあえず回避策としての対応方法をメモ。
症状
PHP8.3.3 / 8.4.24の環境でAdminer6.0.1はログインページ上で以下エラーメッセージが表示された。
Warning: Uninitialized string offset 13288 in /path/to/adminer-6.0.1.php on line 165 Warning: gzinflate(): data error in /path/to/adminer-6.0.1.php on line 167
また、ブラウザのソースコードを確認すると展開後と思われるCSS / JSでエラーになっているようで、表示が崩れているっぽい。
尚、AdminNeo5.6.0は500エラーとなる状況。
対応方法
古めのバージョンを使用する
同じサーバでもAdminer / AdminNeoともに5.5.0までは正常に動作した。
そのためAdminerはこちらから、AdminNeoはこちらから古めのバージョンを入手し、アップロードするとよい。
この方法だと今まで通り1枚のファイルで動作する。
未圧縮のものを使用する
公式ページだと複数のファイルが圧縮された1枚のファイルのバージョンが配布されているが、Githubだと未圧縮のバージョンが入手できるのでこちらを使用する。
未圧縮のバージョンをサーバにアップロード後、ブラウザからはAdminerの場合「adminer/index.php」に、AdminNeoの場合「admin/index.php」にアクセスすると表示される筈。
この方法だと複数のファイルをアップロードすることになるが、最新版を利用可能。
Adminer
公式サイト
Github
https://github.com/vrana/adminer
AdminNeo
公式サイト
Github
関連記事
-
-
ON DUPLICATE KEY UPDATE後にinsert_idを取得すると結果が0になる
MySQLでON DUPLICATE KEY UPDATE句指定し、データの登録 ...
-
-
MySQLのview(ビュー)で仮想的なテーブルを作成する方法
MySQL関連のサイトを見ているとview(ビュー)が云々という記事を見かけた。 ...
-
-
MySQLでデータの集計時に1日の起点を任意の時間に変更する方法
MySQLで1日毎の集計を行う際、例えば2020/01/01のデータは2020/ ...
-
-
MySQLにてdatetime型のカラムを整形し「年月日のみ形式」または「秒のみ省いた形式」で表示する方法
MySQLにてdatetime型のカラムに登録日時等を格納しており、管理画面側で ...
-
-
MySQLでINSERT時にオートインクリメントではないカラムに連番を登録する方法
MySQLでINSERT時にオートインクリメントではないカラムに連番を登録したい ...